Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 04, 2025 - 08:00 UTC
Scheduled
We will be performing scheduled maintenance on our server US1 to improve platform stability and performance.
This maintenance is expected to last approximately 30 minutes and will take place during the following time window:
Eastern Time (ET): 4:00 AM – 4:30 AM Central Time (CT): 3:00 AM – 3:30 AM Mountain Time (MT): 2:00 AM – 2:30 AM Pacific Time (PT): 1:00 AM – 1:30 AM
During this window, some customer websites may be temporarily unavailable or intermittently accessible as we complete the upgrade process.
We appreciate your patience and understanding as we carry out these important improvements. For the latest updates, please continue to monitor this status page.
Posted Apr 03, 2025 - 10:22 UTC
This scheduled maintenance affected: HappyDance Infrastructure (Microsoft Azure).