Maintenance on the US1 shared instance is still in progress. The update process is taking longer than anticipated. Our team are monitoring the process closely and expect services to return to normal shortly. We’ll provide the next update once the instance has been fully restored and verified operational.
Posted Oct 22, 2025 - 11:22 UTC
Update
Customers hosted on the US1 shared instance are currently experiencing a longer than expected maintenance window. Our team is actively working to complete the maintenance and restore normal service as soon as possible. We’ll provide another update once the instance is fully operational.
Posted Oct 22, 2025 - 10:21 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 22, 2025 - 03:00 UTC
Scheduled
Summary We’ll be carrying out planned Microsoft security maintenance on our production infrastructure. Maintenance is applied region by region during the windows listed below.
Expected impact You may see a brief interruption (a couple of minutes) during your region’s window if a server reboot is required. No action is needed from your side.
What we’re doing We’re applying Microsoft security updates as part of our regular patch cycle, followed by service health checks to make sure everything runs smoothly.
Status updates We’ll mark this as in progress during the global window and confirm once all regions are complete.
Thanks for your patience while we keep things secure and reliable.
Posted Oct 20, 2025 - 11:45 UTC
This scheduled maintenance affected: HappyDance Infrastructure (Microsoft Azure).