Azure services have been restored. We have confirmed and reached out to the customers whose sites were affected. We will be sending out PIR reports in the next 72 hours with the details of the incident.
Posted Oct 30, 2025 - 00:43 UTC
Monitoring
Latest update from Microsoft at 19:57 UTC on 29 October 2025
We initiated the deployment of our ‘last known good’ configuration, which has now successfully been completed. Customers may have begun to see initial signs of recovery. We are currently recovering nodes and routing traffic through healthy nodes, and as we make progress in this workstream, customers will continue to see improvement.
At this stage, we anticipate full mitigation within the next four hours as we continue to recover nodes. This means we expect recovery to happen by 23:20 UTC on 29 October 2025. We will provide another update on our progress within two hours, or sooner if warranted.
Posted Oct 29, 2025 - 20:16 UTC
Update
Azure last updated at 17:51 UTC on 29 October 2025 confirming there is still no ETA on rollback and globally all services behind Azure Front Door & Their DNS are offline.
Any customers that have completed the migration to Cloudflare, these issues are not effecting your services.
Posted Oct 29, 2025 - 18:06 UTC
Update
Microsoft Azure have given a further update on the issue (last updated at 17:18 UTC on 29 October 2025):
Starting at approximately 16:00 UTC, we began experiencing Azure Front Door (AFD) issues resulting in a loss of availability of some services. We suspect that an inadvertent configuration change as the trigger event for this issue. We are taking two concurrent actions where we are blocking all changes to the AFD services and at the same time rolling back to our last known good state.
We have failed the portal away from AFD to mitigate the portal access issues. Customers should be able to access the Azure management portal directly.
We do not have an ETA for when the rollback will be completed, but we will update this communication within 30 minutes or when we have an update.
Microsoft Azure has confirmed the issue is related to a wider DNS disruption and is actively performing failover and recovery actions across their Azure Front Door infrastructure.
Our monitoring continues to show that only customers using our legacy Azure Firewall (Azure Front Door) may experience intermittent availability or connectivity issues. All other environments remain fully operational.
We will continue to monitor the situation closely and provide a further update once additional information becomes available from Microsoft.
Posted Oct 29, 2025 - 17:02 UTC
Identified
Microsoft Azure has reported an ongoing DNS-related issue impacting availability of certain Azure services. While most of our environments remain unaffected, we have confirmed that customers using our legacy Azure Firewall (Azure Front Door) may experience site availability issues.
We are continuing to monitor the situation closely and are working to confirm stability following Microsoft’s mitigation actions. Further updates will be provided as new information becomes available.
Posted Oct 29, 2025 - 16:45 UTC
Update
We are continuing with our investigation, Azure is still reporting no issues or loss of service. But we have narrowed down the issue to any customers using our legacy Azure Firewall (Azure Front Door)
Posted Oct 29, 2025 - 16:12 UTC
Investigating
We are currently investigating reports of various sites having connectivity issues and will update further once investigation has concluded
Posted Oct 29, 2025 - 16:00 UTC
This incident affected: HappyDance Infrastructure (Microsoft Azure).