Incident affecting US sites

Incident Report for Happydance

Postmortem

What happened

On September 1, several Happydance hosted career websites had trouble loading search and job listing pages. Some visitors saw pages load slowly or fail to return results during this window. The issue is fully resolved, and all affected career websites are operating normally.

What caused it

A group of career websites run on the same underlying search infrastructure to keep job search fast and consistent. During the affected window, one career website received an unusually high volume of automated traffic to its search pages. That surge used up more capacity on that infrastructure than expected, and once capacity was exhausted, search requests from other career websites running on the same infrastructure also began timing out. Those other websites' own servers and databases were unaffected and continued running normally throughout.

What we did

  • Increased the capacity of the search infrastructure to absorb the extra load.
  • Monitored search and listing pages until performance returned to normal across all affected career websites.

What we're doing next

  • Improving how we detect and filter automated traffic before it reaches search infrastructure.
  • Reviewing monitoring on this infrastructure so we catch a spike like this sooner.

We're sorry for the disruption this caused. If you have questions about how this affected your career website specifically, reach out to your Happydance support contact.

Posted Sep 03, 2026 - 08:52 UTC

Resolved

This incident has now been resolved. Thanks for your patience while we worked through it.
Posted Sep 01, 2026 - 16:25 UTC

Update

We're continuing to investigate and are working closely with the team to identify the root cause. We'll share our next update shortly.
Posted Sep 01, 2026 - 16:02 UTC

Investigating

We're aware of an incident that may have affected our US-based sites. Sites may have experienced intermittent downtime and our team are actively investigating the root cause and working to ensure full stability.
Posted Sep 01, 2026 - 14:52 UTC