Extended Maintenance on US1 Shared Instance

Incident Report for HappyDance

Resolved

Service on the US1 shared instance has been fully restored and operating normally.

The issue was caused by a Windows update on one server that entered a rollback sequence during scheduled maintenance, resulting in temporary unavailability. All other environments completed the same update successfully.

The affected instance was recovered from a validated backup, and post-restoration monitoring confirms stability across all services.

We appreciate your patience during this maintenance window.
Posted Oct 22, 2025 - 16:14 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 22, 2025 - 13:43 UTC

Update

Services on the US1 shared instance have been fully restored and are operating normally.
Our team will continue to monitor system performance closely to ensure continued stability and optimal operation.

A final update will be provided once monitoring confirms sustained normal performance.
Posted Oct 22, 2025 - 13:43 UTC

Update

We’re continuing to work on restoring full service for the US1 shared instance following this morning’s maintenance.
Our team is taking additional recovery steps to ensure the environment is stable before bringing all sites fully back online.

Services may remain intermittently unavailable during this process.
We’ll provide another update once restoration has completed and systems are confirmed stable.
Posted Oct 22, 2025 - 12:57 UTC

Update

The US1 shared instance has begun its automatic restart following the completion of system updates.
This reboot is part of the final maintenance phase and is expected to restore all services shortly.

Our team is monitoring the restart and will provide a further update once the instance is fully online and validated.
Posted Oct 22, 2025 - 12:30 UTC

Monitoring

The US1 shared instance remains in the final stages of maintenance following the earlier Windows update.
While services are gradually restoring, customers may still experience intermittent availability or performance issues as system processes complete and stability is verified.

Our team continue to monitor the environment closely and are working to ensure full service restoration as soon as possible.
Another update will be provided once all systems are confirmed stable.
Posted Oct 22, 2025 - 12:09 UTC

Investigating

Customers hosted on the US1 shared instance are currently experiencing extended downtime following a scheduled maintenance window.
A Windows update on the underlying infrastructure took significantly longer than expected to complete, resulting in temporary service unavailability for hosted websites.

Our team has confirmed that the update has now reached the final stages and the instance is expected to return to service shortly.

We will continue to monitor progress closely and provide an update as soon as the instance is fully restored.

Impact: US1 Shared Instance: Unavailable

All other shared and dedicated instances: Operational
Posted Oct 22, 2025 - 11:34 UTC
This incident affected: HappyDance Infrastructure (Microsoft Azure).